Commit 064287e7 authored by Ansgar Burchardt's avatar Ansgar Burchardt
Browse files

no longer build manual -dbg package

parent fddfbd3e
...@@ -20,8 +20,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends}, ...@@ -20,8 +20,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
Breaks: libdune-functions-dev (<< 2.5.0~) Breaks: libdune-functions-dev (<< 2.5.0~)
Replaces: libdune-functions-dev (<< 2.5.0~) Replaces: libdune-functions-dev (<< 2.5.0~)
Recommends: cmake, python3 Recommends: cmake, python3
Suggests: libdune-common-dbg (= ${binary:Version}), Suggests: libdune-common-doc (= ${source:Version})
libdune-common-doc (= ${source:Version})
Provides: ${dune:shared-library} Provides: ${dune:shared-library}
Description: toolbox for solving PDEs -- basic classes (development files) Description: toolbox for solving PDEs -- basic classes (development files)
DUNE, the Distributed and Unified Numerics Environment is a modular toolbox DUNE, the Distributed and Unified Numerics Environment is a modular toolbox
...@@ -31,20 +30,6 @@ Description: toolbox for solving PDEs -- basic classes (development files) ...@@ -31,20 +30,6 @@ Description: toolbox for solving PDEs -- basic classes (development files)
. .
This package contains the development files for the basic classes. This package contains the development files for the basic classes.
Package: libdune-common-dbg
Section: debug
Priority: extra
Architecture: any
Multi-Arch: same
Depends: ${misc:Depends}, libdune-common-dev (= ${binary:Version})
Description: toolbox for solving PDEs -- basic classes (debug symbols)
DUNE, the Distributed and Unified Numerics Environment is a modular toolbox
for solving partial differential equations (PDEs) with grid-based methods.
It supports the easy implementation of methods like Finite Elements (FE),
Finite Volumes (FV), and also Finite Differences (FD).
.
This package contains the debug symbols for the basic classes.
Package: libdune-common-doc Package: libdune-common-doc
Section: doc Section: doc
Architecture: all Architecture: all
......
...@@ -20,6 +20,3 @@ override_dh_install-arch: ...@@ -20,6 +20,3 @@ override_dh_install-arch:
override_dh_installdocs-indep: override_dh_installdocs-indep:
dh_installdocs dh_installdocs
dh_sphinxdoc dh_sphinxdoc
override_dh_strip:
dh_strip --dbg-package=libdune-common-dbg
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment