Liebe Gitlab-Nutzer, lieber Gitlab-Nutzer,
es ist nun möglich sich mittels des ZIH-Logins/LDAP an unserem Dienst anzumelden. Die Konten der externen Nutzer:innen sind über den Reiter "Standard" erreichbar.
Die Administratoren


Dear Gitlab user,
it is now possible to log in to our service using the ZIH login/LDAP. The accounts of external users can be accessed via the "Standard" tab.
The administrators

Commit 88bf556a authored by Praetorius, Simon's avatar Praetorius, Simon
Browse files

debian packaging updated

parent aa55d10d
Pipeline #1650 passed with stages
in 44 minutes and 3 seconds
......@@ -2,7 +2,7 @@ Source: amdis
Maintainer: @PACKAGE_CONTACT@
Section: contrib/misc
Priority: optional
Standards-Version: 3.9.2
Standards-Version: 3.9.8
Vcs-Git: https://gitlab.math.tu-dresden.de/iwr/amdis.git
Homepage: https://gitlab.math.tu-dresden.de/iwr/amdis
Build-Depends: debhelper (>= 9), libboost-date-time-dev (>= 1.48),
......@@ -17,8 +17,8 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, libboost-date-time-dev (>= 1.48),
libboost-filesystem-dev (>= 1.48), libboost-iostreams-dev (>= 1.48),
libboost-program-options-dev (>= 1.48), libboost-system-dev (>= 1.48),
zlib1g-dev (>= 1.2), cmake (>= 2.8.10), pkg-config (>= 0.26)
Recommends: libamdis (= ${source:Version}), libamdis-par (= ${source:Version})
Suggests: libamdis-debug (= ${source:Version}), libamdis-par-debug (= ${source:Version})
Recommends: libamdis (= ${binary:Version}), libamdis-par (= ${binary:Version})
Suggests: libamdis-debug (= ${binary:Version}), libamdis-par-debug (= ${binary:Version})
Description: @PACKAGE_DESCRIPTION_SUMMARY@
@PACKAGE_DESCRIPTION@
.
......@@ -26,7 +26,7 @@ Description: @PACKAGE_DESCRIPTION_SUMMARY@
Package: libamdis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis-dev (= ${source:Version}),
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis-dev (= ${binary:Version}),
libsuitesparse-dev (>= 4.2.1)
Description: @PACKAGE_DESCRIPTION_SUMMARY@
@PACKAGE_DESCRIPTION@
......@@ -35,7 +35,7 @@ Description: @PACKAGE_DESCRIPTION_SUMMARY@
Package: libamdis-par
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis-dev (= ${source:Version}),
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis-dev (= ${binary:Version}),
petsc-dev (>= 3.3), libparmetis-dev (>= 3.0), libmetis-dev (>= 5.0)
Description: @PACKAGE_DESCRIPTION_SUMMARY@ (parallel Release-mode)
@PACKAGE_DESCRIPTION@
......@@ -44,7 +44,7 @@ Description: @PACKAGE_DESCRIPTION_SUMMARY@ (parallel Release-mode)
Package: libamdis-debug
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis (= ${binary:Version})
Description: @PACKAGE_DESCRIPTION_SUMMARY@ (Debug-mode)
@PACKAGE_DESCRIPTION@
.
......@@ -52,7 +52,7 @@ Description: @PACKAGE_DESCRIPTION_SUMMARY@ (Debug-mode)
Package: libamdis-par-debug
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis-par (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, libamdis-par (= ${binary:Version})
Description: @PACKAGE_DESCRIPTION_SUMMARY@ (parallel Debug-mode)
@PACKAGE_DESCRIPTION@
.
......
......@@ -24,11 +24,11 @@ if (NOT IS_RELEASE)
set(PACKAGE_VERSION "${PACKAGE_VERSION}~rc${PACKAGE_RELEASE_CANDIDATE}")
endif ()
set(PACKAGE_VERSION "${PACKAGE_VERSION}~ppa5~${PACKAGE_DISTRIBUTION}")
set(PACKAGE_VERSION "${PACKAGE_VERSION}~${PACKAGE_DISTRIBUTION}")
set(PACKAGE_VERSION_FULL "${PACKAGE_VERSION}-1")
set(PACKAGE_CONTACT "Simon Praetorius <simon.praetorius@tu-dresden.de>")
set(PACKAGE_SOURCE "<https://gitlab.math.tu-dresden.de/iwr/amdis.git>")
set(PACKAGE_SOURCE "<https://gitlab.mn.tu-dresden.de/iwr/amdis.git>")
set(PACKAGE_DESCRIPTION_SUMMARY "A C++ library to solve a broad class of PDEs using adaptive finite elements.")
set(PACKAGE_DESCRIPTION_FILE "${CMAKE_SOURCE_DIR}/README.md")
......
......@@ -31,10 +31,10 @@ override_dh_auto_configure:
-DENABLE_PARALLEL_DOMAIN:BOOL=ON
override_dh_auto_build:
dh_auto_build --builddirectory=build_libamdis --package=libamdis --max-parallel=2
dh_auto_build --builddirectory=build_libamdis_par --package=libamdis-par --max-parallel=2
dh_auto_build --builddirectory=build_libamdis_debug --package=libamdis-debug --max-parallel=2
dh_auto_build --builddirectory=build_libamdis_par_debug --package=libamdis-par-debug --max-parallel=2
dh_auto_build --builddirectory=build_libamdis --package=libamdis --max-parallel=24
dh_auto_build --builddirectory=build_libamdis_par --package=libamdis-par --max-parallel=24
dh_auto_build --builddirectory=build_libamdis_debug --package=libamdis-debug --max-parallel=24
dh_auto_build --builddirectory=build_libamdis_par_debug --package=libamdis-par-debug --max-parallel=24
override_dh_auto_install:
dh_auto_install --builddirectory=build_libamdis --package=libamdis
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment