Commit f161a986 authored by Naumann, Andreas's avatar Naumann, Andreas
Browse files

allowing newer boost and documentation

parent 6e34f34c
...@@ -623,6 +623,12 @@ foreach(mtl4_file in ${mtl4_files}) ...@@ -623,6 +623,12 @@ foreach(mtl4_file in ${mtl4_files})
get_filename_component(mtl4File_path ${mtl4_file} PATH) get_filename_component(mtl4File_path ${mtl4_file} PATH)
list(APPEND deb_add_dirs "include/amdis/mtl4/boost/${mtl4File_path}") list(APPEND deb_add_dirs "include/amdis/mtl4/boost/${mtl4File_path}")
endforeach(mtl4_file) endforeach(mtl4_file)
#install documentation
FILE(GLOB DOCS "${AMDIS_SOURCE_DIR}/doc/*.pdf")
INSTALL(FILES ${DOCS} DESTINATION share/amdis/doc)
list(APPEND deb_add_dirs "share/amdis/doc")
list(REMOVE_DUPLICATES deb_add_dirs) list(REMOVE_DUPLICATES deb_add_dirs)
#PACKAGES #PACKAGES
...@@ -639,8 +645,8 @@ configure_file(${AMDIS_SOURCE_DIR}/preinst.in ...@@ -639,8 +645,8 @@ configure_file(${AMDIS_SOURCE_DIR}/preinst.in
configure_file(${AMDIS_SOURCE_DIR}/postrm.in configure_file(${AMDIS_SOURCE_DIR}/postrm.in
${AMDIS_BINARY_DIR}/postrm ${AMDIS_BINARY_DIR}/postrm
@ONLY) @ONLY)
set(CPACK_RPM_PACKAGE_REQUIRES "boost-devel == 1.42, ${RPM_DEPEND_STR}") set(CPACK_RPM_PACKAGE_REQUIRES "boost-devel >= 1.42, ${RPM_DEPEND_STR}")
set(CPACK_DEBIAN_PACKAGE_DEPENDS "libboost-dev (== 1.42), libboost-iostreams-dev (== 1.42), libboost-system-dev (== 1.42), libboost-filesystem-dev (== 1.42)") set(CPACK_DEBIAN_PACKAGE_DEPENDS "libboost-dev (>= 1.42), libboost-iostreams-dev (>= 1.42), libboost-system-dev (>= 1.42), libboost-filesystem-dev (>= 1.42)")
set(CPACK_DEBIAN_PACKAGE_CONTROL_EXTRA "${AMDIS_BINARY_DIR}/preinst" "${AMDIS_BINARY_DIR}/postrm") set(CPACK_DEBIAN_PACKAGE_CONTROL_EXTRA "${AMDIS_BINARY_DIR}/preinst" "${AMDIS_BINARY_DIR}/postrm")
include(CPack) include(CPack)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment